Help Me/Question Mysql Database Connectivity Issue

Status
Not open for further replies.
C

cruise05

Hi,
I have installed LiteSpeed on my server. Currently I have apache/cpanel and I followed all the wiki's (I selected to NOT import the apache config during installation) and installed LiteSpeed, loaded the apache config in the control panel and also compiled lsphp according to the other wiki.
MySQL does not connect for some reason.
I have set a 1000 port offset and both my portal and forums do not connect to database.
For eg. makemoneykingdom:1080/forums/ (Thats the error it gives when it cannot connect to database) although regular apache works fine -makemoneykingdom
I configured PHP with the SAME options.. see phpinfo - makemoneykingdom:1080/phpinfo.php
and of Apache - makemoneykingdom/phpinfo.php
I know thats its some PHP/MySQL issue, but I cant fathom what it is, as everything is followed to the dot and I retried multiple times..
 

clau

White Belt
Hi,

The most common reason for a MySQL connect error is a bad mysql username or password or a bad MySQL server setting.
You can check the username in the control panel of your site and the MySQL server in the phpMyAdmin. It is on the first page when you go to phpMyAdmin and select your database.
 

jason146

White Belt
yes in most cases the problem is always in the database username.password or database name but some times the server name also required other than the simple "localhost"
 
Status
Not open for further replies.
Top